Hey! So I built my rig about 2 years ago and everything has been fine since then. A few days ago I wanted to change the LED colour on the block but it wasnt showing up in the corsair. Desperate I tried to switch the wire, update the software and shit and nothing seemed to work. I had reinstalled windows 10 again as some software stuff happened.
Anyways the computer starts hanging and I restart it. I ran the Asus Ai software which overclocked the system by pushing the optimize 5 way button, I baseclocked it once I knew ke actually this is overclocking thw cpu. The bios stated that cpu fan wasnt working and cpu was heating up. It seems to start up at 37 and go up from there to 90. Also the pump isnt showing up on the link software that is the speed of pump and fans

The list of things I did after that:
• Checked to see if the block is correctly seated
• Changed thermal paste which didn't help at all... tried a toothpaste diy thermal paste which stablized the temps for a while and then went up to 90. Bought a new paste and applied with the same results
The fans are working at full speed
I can feel the water flowing inside the tubes
The fan speed is turned all the way up in asus bios
One of the tubes coming from the block was heated up once I unplugged the cooler from motherboard and started it up which means the pump is working
Underclocked the cpu BLCK to 50 didnt help

Anyways Im running out of things to test whether it is dead or not and What should I do. I hope this community can help me out.
Here are the specs:
> Intel I7 6700k (Skylake)
> Gigabyte G1 Gaming R9 390
> Asus Rog Maximus VIII Ranger
> Corsair Vengeance LPX DDR4 clocked at 3200Mhz
> Corsair Hydro h100i v2 AIO Cpu Cooler
> Corsair CM 750M PSU
> Corsair Force LE SSD 240 Gb
> Toshiba HDD 480 Gb 2.5" drive
> CoolerMaster Mastecase 5

Any help would be appreciated