• Amused
  • Angry
  • Bored
  • Busy
  • Cheeky
  • Cold
  • Confused
  • Cool
  • Devilish
  • Fine
  • Hacker
  • Happy
  • In Love
  • Innocent
  • Lonely
  • Nerdy
  • Pensive
  • Roflol
  • Sad
  • Starving
  • Stressed
  • Yeehaw
  • Results 1 to 8 of 8

    Thread: Display driver has crashed problem: please help

    1. #1
      PG Addict
      I am:
      Devilish
       

      Location
      Lahore
      Posts
      272
      My Consoles
      PC , PS3
      My PC Specs
        Monitor: Samsung 19" LED
        CPU: i5-4670 3.8 Ghz
        Motherboard: GA-B85M-D3H
        Memory: Kingston 4gb
        GPU: Radeon HD6850 1gb
        HDD: 1 TB Western Digital
        PSU: Cooler master 500w
        OS: Windows 8.1 64-bit

      Display driver has crashed problem: please help

      Guys as you know, I recently upgraded my pc from core2duo to i5-haswell. along with mobo and ram.

      Now, I have reinstalled windows twice, once windows 8, and then wiped it and installed windows 7, both 64 bit...but the same problem persists...display driver has stopped and recovered. No game is running. Direct x is latest, my amd drivers are the latest. Games won't even load till the main menu. First Alan wake was running but no other game was running, then I installed beta drivers, it started chopping up, I reverted back but it was still choppy. I wiped windows 8 x64 and then installed win 7 x64...Now, Farcry 3 is running, but there was a a lot of screen tearing. But apart from it, Black flag, Tombraider, Alanwake, Mass effect trilogy, Batman arkahm origins, street fighter 4 etc no game is running. I have been getting some strange errors when game starts and then aborts, these are:

      Failed to lock the vortex buffer
      Fatal error in Direct 3d
      Driver has stopped and recovered.
      Tomb raider has stopped working.

      Some games give no errors, but the screen goes black and then nothing happens. The computer does not get stuck though...i can open task manger to get back to desktop....

      I am at my wits end, I have installed the Beta drivers but they are no help either. I did think that may be the GPU isn't getting enough power..but I am not sure, how is Farcry running then?

      My specs:

      i5-4670
      GA-B85M-D3H
      4gb ram @1600
      Cooler Master extreme power plus RS-500-PCAR-A3. (500w)
      XFX HD 6850 1 Gb.

      Do you think the GPU is underpowered? (I have no other PSU to check it). Or is it a driver issue? Before the upgrade, with my previous core2duo and ddr2 mobo and ram, everything was fine, I did get an occasional display driver has stopped and recovered message but it didn't hurt the games at all. Right now, I can't play anything and even normal window operations are being stuck in the display driver error. Please suggest...thank you.
      Last edited by neox3d; 16-02-14 at 04:49 PM.

    2. #2
      King Of The Kings
      I am:
      Happy
       

      Location
      Karachi
      Posts
      365
      My Consoles
      PC , XB360 , PS3
      My PC Specs
        Monitor: SHITTY LAPTOP
        CPU: SHITTY LAPTOP
        Cooler: SHITTY LAPTOP
        Motherboard: SHITTY LAPTOP
        Memory: SHITTY LAPTOP
        GPU: SHITTY LAPTOP
        HDD: SHITTY LAPTOP
        Chassis: SHITTY LAPTOP
        PSU: SHITTY LAPTOP
        Soundcard: SHITTY LAPTOP
        OS: SHITTY LAPTOP
      Sorry, But i think your card is dying .. same thing happened to my gtx 660

    3. #3
      PG Newbie
      I am:
      Angry
       

      Location
      LAHORE
      Posts
      11
      My Consoles
      PC , PS3 , PS4
      I had this problem but it has solved...this due to RAM ... Check out your RAM one by one..

    4. #4
      TXAA
      I am:
      Busy
       

      Location
      Sadiqabad, Distt. Rahimyar Khan
      Posts
      8,313
      My Consoles
      PC , PS3
      My PC Specs
        Monitor: Samsung 40" EH5000 Full HD 1080p
        CPU: Intel Core i5 2400 3.1-3.4GHz
        Cooler: Cooler Master Eagle , 5 x 120mm LED fans
        Motherboard: Asus P8H61-M LE
        Memory: Kingston DDR3 4Gb
        GPU: Palit GTX 560 TI 448 Cores
        HDD: Seagate 2TB 7200.14
        Chassis: Casecom RHEIN KM-9288 RED
        PSU: Xigmatek Tauro 600w
        Soundcard: Realtek ALC 887
        OS: Windows 8.1 Pro X64
      ITS EITHER PSU OR GPU
      most likely its PSU, if its gpu then its psu which make it problematic
      Increase vcore of gpu a bit and see if it helps

    5. #5
      PG Xtremist
      I am:
      Stressed
       

      Location
      Karachi
      Posts
      2,682
      My Consoles
      PC
      My PC Specs
        Monitor: 20 inch Acer LCD
        CPU: Intel core i5 2500k
        Cooler: Xigmatek Dark Night
        Motherboard: AsRock z75 pro3
        Memory: G skil 4gb ram 1333mhzl
        GPU: Sapphire HD 7950
        HDD: WD 500GB 16mb cache
        Chassis: Thermaltake Commander
        PSU: Strike X 600watts PSU
        Soundcard: Onboard HD Audio
        OS: Windows Vista x86
      Actually there are more than 20 reasons for the specified error. SInce you have formatted your windows, updated to latest drivers. I guess updating your motherboard bios wont hurt you. At least it solved my problem when i had this issue with my old Nvidia 8800gt

    6. #6
      PG Xtremist
      I am:
      Roflol
       

      Location
      islamabad and jhang
      Posts
      4,753
      My Consoles
      PC
      My PC Specs
        Monitor: Samsung LED s20b300 20"
        CPU: Intel core i5 4430
        Cooler: stock
        Motherboard: Gigabyte B85M D3H
        Memory: Gskill ripjaws 4gbx3=12gb
        GPU: Sapphire R9 270x dual x OC
        HDD: Seagate barracuda 1 tb
        Chassis: Xigmatech utgard
        PSU: Thermaltek lite power 600 watts
        Soundcard: built in 7.1 ch
        OS: windows 8.1 pro x64
      It must be ur gpu
      I faced exactly this isue with my 7770 which was just 1week old claimed my gpu and problm solved

      Sent from my Sony Xperia S using Tapatalk Pro

    7. #7
      PG Addict
      I am:
      Devilish
       

      Location
      Lahore
      Posts
      272
      My Consoles
      PC , PS3
      My PC Specs
        Monitor: Samsung 19" LED
        CPU: i5-4670 3.8 Ghz
        Motherboard: GA-B85M-D3H
        Memory: Kingston 4gb
        GPU: Radeon HD6850 1gb
        HDD: 1 TB Western Digital
        PSU: Cooler master 500w
        OS: Windows 8.1 64-bit
      Guys I just saw a new error, nfs speed.exe was denied access to graphics hardware...anyone know why this error is occurring? Using windows 8.1 fresh installed.

    8. #8
      PG Addict
      I am:
      Devilish
       

      Location
      Lahore
      Posts
      272
      My Consoles
      PC , PS3
      My PC Specs
        Monitor: Samsung 19" LED
        CPU: i5-4670 3.8 Ghz
        Motherboard: GA-B85M-D3H
        Memory: Kingston 4gb
        GPU: Radeon HD6850 1gb
        HDD: 1 TB Western Digital
        PSU: Cooler master 500w
        OS: Windows 8.1 64-bit
      Using it in the 4x slot for now...I have to see bro Mave but Ihaven't been able to...so stuck up in work ...

     

     

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    All times are GMT +5. The time now is 12:50 PM.


    Back to Top Copyright 2014 PakGamers. All rights reserved.